Schema not working in Pipeline, but works OK in Visual Studio

From: The Gremlin (imagremlin_at_hotmail.com)
Date: 02/21/05

  • Next message: MattBell: "Re: Correlation confusion"
    Date: Mon, 21 Feb 2022 13:07:03 -0800
    

    My project has a couple of dozen schemas, and almost all of them work. I have
    one renegade schema, that will validate a document inside the VS environment,
    but will fail like this when placed in a pipeline:

    There was a failure executing the receive pipeline:
    "Banesco.CCE.Pipelines.RespComandoORD" Source: "Flat file disassembler"
    Receive Location: "D:\svs005\RootSib\REP\*.*" Reason: Unexpected end of
    stream while looking for:
    Positional data (length is 3)
    The current definition being parsed is REP. The stream offset where the
    error occured is 65. The line number where the error occured is 2. The column
    where the error occured is 0.

    One curious note is that the document the schema represents has only 1 line.
    The file I am droping in the Receive Location has 1 line and it validates OK
    in VS. Yet the schema (only when in the pipe) seems to be looking for
    additional data (the file is 65 bytes long)

    The pipeline tool wont help, I just get this:

            Message: None of the disassembler components could recognize
    a data

    All help is deeply appreciated.


  • Next message: MattBell: "Re: Correlation confusion"

    Relevant Pages

    • RE: Schema not working in Pipeline, but works OK in Visual Studio
      ... > There was a failure executing the receive pipeline: ... The stream offset where the ... > One curious note is that the document the schema represents has only 1 line. ... > The pipeline tool wont help, ...
      (microsoft.public.biztalk.general)
    • Re: Receive synchronous response in biztalk 2006
      ... can still use this pipeline and send my XML messages through it. ... no. Th epasthrough pipeline will do almost nothing. ... The XMLReceiv epipeline wont validate the input! ... deployed schema. ...
      (microsoft.public.biztalk.general)
    • Validation in Pipeline
      ... I want to validate all incoming documents if they are known and are ... do so I created a BizTalk project with a receive pipeline. ... I added all schemas so that I get a schema collection of valid ...
      (microsoft.public.biztalk.general)
    • RE: Error working with a csv flat file
      ... Do I need to use an Orchestration with this and include a flat file ... > The properties set at the schema level are Schema Editor Extensions Flat ... > Occurs unbounded, Child Delimeter Type Character, Child Delimiter, Child ... > When I validate my schema it validates fine. ...
      (microsoft.public.biztalk.general)
    • Re: XML Schema validation error
      ... validating XML reader in dotnet code. ... so I need to fix the schema so that it validates. ... I then validate an xdp file ...
      (microsoft.public.dotnet.xml)